Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Incorrect charges and invoice amounts for some accounts
Incident Report for Hotjar
Resolved
Posted 12 days ago. Sep 10, 2019 - 18:35 CEST
Monitoring
Our engineers have released a fix for this issue and are currently monitoring to ensure there are no more occurrences.
Posted 12 days ago. Sep 10, 2019 - 17:46 CEST
Identified
We’ve identified the issue with incorrect charges and invoices. Our engineers are working to resolve it: https://help.hotjar.com/hc/en-us/articles/360035618713-10th-September-2019-Incorrect-charges-and-invoice-amounts
Posted 12 days ago. Sep 10, 2019 - 16:33 CEST
Investigating
We’re currently investigating an issue with customers being charged twice or receiving incorrect amounts in their invoices and our engineers are working to resolve it
Posted 12 days ago. Sep 10, 2019 - 16:09 CEST