Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Engage is unavailable
Incident Report for Hotjar
Resolved
This incident is now resolved. Thank you for bearing with us!
Posted Nov 25, 2024 - 12:35 UTC
Investigating
The Engage product is currently down.

Our engineers are working to fix the issue ASAP and will post updates to status.hotjar.com.

Thanks for bearing with us!
Posted Nov 25, 2024 - 11:31 UTC