Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Invoice access and downloading issues
Incident Report for Hotjar
Resolved
Thank you for your patience while our engineers worked on a fix!

We have deployed a solution for this, and invoices are now accessible in your account.
Posted May 22, 2023 - 15:28 UTC
Identified
Our engineers have identified the root cause of an issue affecting some users who are accessing or downloading their invoices. A fix for this is in progress.

We'll post an update to let you know when we're deploying and monitoring the fix. Thanks again for bearing with us!
Posted May 22, 2023 - 08:44 UTC