Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Incoming Feedback creation unavailable
Incident Report for Hotjar
Postmortem

On June 17th at 9:55AM UTC our engineers identified an issue with Incoming Feedback creation not functioning properly for some users.

What happened?

Hotjar rolled out a Slack integration, where Incoming Feedback responses can be sent directly to Slack. This caused a temporary issue where an error was returned by the server when a user created a Incoming Feedback widget. The widget would still be created, but due to the error the interface wouldn't reflect this.

Why did this issue occur?

A misconfiguration in the API endpoint that handled the creation of Incoming Feedback widgets tried to always find a Slack integration. When a Slack integration wasn't found an error was thrown.

What will we do to prevent this from happening in the future?

An internal postmortem was held and it was identified that some stricter testing guidelines - both for automated tests, as well as manual - needs to be drafted. There was also a discussion around a general improvement of error handling in the Hotjar API that will be followed up with backend engineers to improve on.

Posted Jun 17, 2020 - 13:56 UTC

Resolved
The issue has been resolved. Thank you for your patience!
Posted Jun 17, 2020 - 13:47 UTC
Monitoring
Our engineers have fixed the issue and are monitoring the situation to make sure everything is working smoothly again.
Posted Jun 17, 2020 - 12:12 UTC
Identified
We’ve identified the issue with Incoming Feedback creation and our engineers are working to resolve it.
Posted Jun 17, 2020 - 10:23 UTC
Update
We are continuing to investigate this issue.
Posted Jun 17, 2020 - 10:15 UTC
Investigating
We’re currently investigating an issue with Incoming Feedback creation. Our engineers are working to fix the issue ASAP and will post updates to status.hotjar.com. Thanks for bearing with us!
Posted Jun 17, 2020 - 10:15 UTC
This incident affected: Application (Incoming Feedback).