Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Some customers unable to modify their subscription
Incident Report for Hotjar
Resolved
This incident is resolved. Thanks for bearing with us!
Posted Aug 22, 2024 - 14:21 UTC
Monitoring
Our engineers have implemented a fix for this issue and customers should now be able to manage their subscriptions without error. We will continue to monitor this situation to confirm that the fix was successful.
Posted Aug 22, 2024 - 13:49 UTC
Identified
Our engineers have identified the issue and are working on a fix.
Posted Aug 22, 2024 - 13:38 UTC
Investigating
We've received reports that customers are unable to modify their subscription.

Our team is investigating this issue and plan to get this resolved as soon as possible.
Posted Aug 22, 2024 - 13:32 UTC