Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Surveys erroneously submitted skipped answer fields to the responses list
Incident Report for Hotjar
Postmortem

On 24th March 2021, at 9:36 am UTC our engineers identified an issue with Surveys.

What happened?

When creating a Survey, questions can be marked as “Optional”, allowing the respondent to skip the question. Due to a bug, introduced as part of a feature update, questions that a respondent started filling out and then clicked “Skip” would have the filled-in answer submitted to our servers.

Why did this issue occur?

On 2nd March 2021, we released an update to enhance our Survey metrics. Part of this was to track questions that a visitor might choose to skip, as we didn't have any visibility into this metric.

In this update, a bug was introduced where the answer would be included in the response, even though the “Skip” button was clicked.

What will we do to prevent this from happening in the future?

We will hold an internal postmortem and update this report later.

Posted Mar 24, 2021 - 14:02 UTC

Resolved
We found and implemented a fix for an issue where if a respondent started filling out an optional question, but then clicked "Skip", the answer would still be included and sent to our servers. It was resolved today at 12:59 pm UTC.
Posted Mar 24, 2021 - 08:30 UTC