Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Some upgrades not billed correctly
Incident Report for Hotjar
Update
Invoices for upgrades from an Observe Business Plan to an Observe Scale Plan since 30 Apr 2024 will be processed with a delay
Posted May 17, 2024 - 10:32 UTC
Identified
Our engineers have identified the issue that led to this incident and are now working on a solution.
Posted May 16, 2024 - 11:27 UTC
Investigating
We're investigating an issue where some upgrades from an Observe Business Plan to an Observe Scale Plan since 30 Apr 2024 may not have been billed correctly
Posted May 15, 2024 - 11:54 UTC