Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Temporary loss of connection to the database
Incident Report for Hotjar
Postmortem

On 23rd June, 2020 at 3:40 UTC our engineers identified an issue with database connectivity. This was resolved by 4:04 UTC.

What happened?

An automatic failover event on the primary database took place. This is a method for the database to quickly switch to a replica when a fault is detected. After the failover our connection did not re-establish correctly and caused a partial outage for approximately 26 minutes.

Why did this issue occur?

Normally with a failover the database connection is automatically restored, guaranteeing minimum downtime. We’re still investigating the reasons this didn’t occur.

What will we do to prevent this from happening in the future?

Engineers will investigate further on why the connection did not restore and what caused the failover attempt. That way we can apply further measures to avoid a repeat incident.

Posted Jun 23, 2020 - 07:39 UTC

Resolved
Earlier our engineers encountered an issue with database connections. They restarted the necessary components and restored full system functionality by 4:04 UTC.
Posted Jun 23, 2020 - 01:30 UTC