Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Price preview shows incorrect pricing when moving to yearly
Incident Report for Hotjar
Resolved
This incident is now resolved. Thanks for bearing with us!
Posted Feb 19, 2024 - 12:39 UTC
Identified
We’ve identified an incident with price previews when moving to a yearly subscription.

Our team is already working on developing a fix and we hope to share more news soon.

Thanks for bearing with us!
Posted Feb 19, 2024 - 11:23 UTC