Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Some customers experience issues making payments or updating payment details
Incident Report for Hotjar
Resolved
This incident has been resolved! Thanks for hanging in there with us 😊
Posted Nov 14, 2023 - 17:20 UTC
Investigating
We’ve declared an incident to investigate reports of payment issues. We’ve formed an incident response team, and they’re investigating this together.

We’ll post further updates to this incident report when we have them, but in the meantime, we’re really sorry for the trouble some users experience while making payments or updating payment methods. Thanks a lot for bearing with us!
Posted Nov 14, 2023 - 15:39 UTC