Hotjar Service Status


This is Hotjar's status page, where you can get updates on how our systems are doing. If there are interruptions to service, we will post a report here.

Report an issue
Recordings list loading error
Incident Report for Hotjar
Postmortem

On 19th November 2020 at 12:22 UTC our engineers identified an issue with the Recording list page.

What happened?

In some rare cases, depending on the order in which web requests returned, the Recording list page could crash. This was extremely uncommon, but it did affect some of our users.

Why did this issue occur?

We deployed some front-end code on the 9th of November 2020 with the aim of improving the experience of setting up a new site specifically from a Recording point of view. This issue did not show up in testing.

How will we prevent this happening in future?

When introducing front-end experiments like this we will focus on eliminating cases where race conditions can cause errors.

Posted Nov 20, 2020 - 11:54 UTC

Resolved
This incident has been resolved. Thanks for hanging in there!
Posted Nov 19, 2020 - 14:50 UTC
Monitoring
We have deployed a fix and are monitoring the results.
Posted Nov 19, 2020 - 13:37 UTC
Identified
We have identified the issue and we're working on fixing it. Thanks for your patience.
Posted Nov 19, 2020 - 12:44 UTC
Investigating
We are currently investigating an issue in which the recordings list page crashes for a small number of users. We're working to fix it ASAP and will post updates to status.hotjar.com. Thanks for bearing with us!
Posted Nov 19, 2020 - 12:37 UTC
This incident affected: Application (Recordings).